Oracle Identity Manager – OIM 11g R2 RCU Error


19/02/2013

Are you trying to install Oracle Identity Manager – OIM 11gR2 on Oracle Enterprise Linux 6 64-bit?

Do you plan on running the OIM 11gR2 RCU to create some repositories during the installation?

If you answered yes to these two questions then this little bit of information may be of assistance to you. Running the RCU on a 64-bit system will result in errors like this one:

RCU- 6136: Error while trying to execute SQLPlus action

This RCU-6136 error is a result of the RCU installer being run on a 64-bit JDK of which portions of the RCU installer still rely on a 32-bit environment.   The result is that even if you are creating the repository on a 64-bit system you will encounter this error.  It means you will need to run the RCU on a 32bit JVM for a successful install.   NOTE:  Running it either remotely or locally using the –d32 option will not work.

Hope this is a help.

No Results